Subject: More Hack-n-Roll

From: [email-masked] (Jim Flanagan)
Date: 18 Oct 91 17:20:10 GMT

In the spirit of the UNIX rock adaptations, I drag this out.

UNIX*	[To the tune of _Money_ by Pink Floyd]
----

UNIX, it's a gas;
grab that VAX with
both hands and
make it crash.

UNIX, it's a hit;
Don't give me that
PC DOS Bullshit.

I'm into well benchmarked
POSIX Open Systems
I think I need a RISC chip.

UNIX, jmp back;
I'm all niced now
pop your frame off of
my stack.

----
*UNIX is a trademark of AT&T
-- 
  Jim Flanagan			| 
  [email-masked]	| Pragmatism is the defenestration of idealism. 
  Systems Programmer		| Diem ex dies with the most toys wins.
  UofW Statistics		|

---

From: [email-masked] (Matt Crawford)
Date: 18 Oct 91 18:26:42 GMT

Cycles For Nothing

(i want my
 i want my
 i want my X-MP!)

Now look at them yo-yo's that's
	the way you do it
You run the fortran on the X-MP
That ain't hackin' that's the way
	you do it
Cycles for nothin', gigabits for free
Now that ain't hackin' that's the way
	you do it
Lemme tell ya them guys ain't dumb
Maybe Monte Carlo on a three-quark
	system
Maybe design a little neutron bomb

 We gotta install microwave uplinks
 Custom fuzzballs for everyone
 We gotta link up DDS circuits
 BERT and loopback tests to run

See the kid professor with the blue
	jeans and the necktie
Yeah buddy that's his own hair
That kid professor got his Nobel
	prize now
That kid professor he's a millionaire

 We gotta install microwave uplinks
 Custom fuzzballs for everyone
 We gotta link up DDS circuits
 BERT and loopback tests to run

I shoulda stuck to writing in fortran
I shoulda kept that old 029
Look at that output, he got it stacked
	up to the ceilin'
I bet he ain't read one line
And in there, what's that?
	A hundred postdocs?
Bangin' on the keyboards like some
	chimpanzees
That ain't hackin' that's the way you
	do it
Cycles for nothin', gigabits for free

 We gotta install microwave uplinks
 Custom fuzzballs for everyone
 We gotta link up DDS circuits
 BERT and loopback tests to run

		by Matt Crawford

---

From: [email-masked] (Jamie Mason)
Date: 19 Oct 91 08:34:18 GMT

Since I posted 'Unix Wizard', I thought up another Unix-specific
song inspired by The Who...

The Swapper 	(Concocted by Jamie Mason to 'The Seeker' by The Who)
-----------

I've looked in kernel memory,
I've looked in the tables.
I try to find some core
For fifty million pages.
They call me the swapper.
I've been searching low and high.
Unix won't run out of memory
Till the day I die.

I asked Dennis Ritchie,
I asked Ken Thompson.
I asked comp.unix.wizards,
But they couldn't help me either.
They call me the swapper.
I've been searching low and high.
Unix won't run out of memory
Till the day I die.

People tend to hate me,
Cause I swap too slow.
As I page out their jobs
They want to shake my hand.
Focusing on swap space,
Investigating pagefaults,
I'm a pagedaemon,
I'm a very desperate hack.

Unix won't run out of memory
Till the day I die.

I learned how to raise resident set size.
Yeah, but look at this process it's mem'ry bound!
I'm happy when you segfault,
and when you run thrash.c I crash.
I get values but I
Don't know how or why!

I'm looking for core,
You're looking for CPU,
We're running on the same box,
And we don't know what to do!
They call me the swapper.
I've been searching low and high.
Unix won't run out of memory
Till the day I die.

---
Jamie  ...  The Third Sync()
Written On  Saturday, October 19, 1991  at  04:31:16am EDT

---

From: [email-masked] (Brad Morrison)
Date: Sat, 19 Oct 1991 19:10:46 GMT

UNIX Man 	(to The Beatles' "Nowhere Man")
			--------

		He's a real UNIX Man
		Sitting in his UNIX LAN
		Making all his UNIX .plans
		For nobody

		Knows the blocksize from 'du'
		Cares not where /dev/null goes to
		Isn't he a bit like you
		And me?

		UNIX Man, don't worry
		It's the tube that's blurry
		UNIX Man
		The new kernel boots, just like you had planned

		He's as wise as he can be
		Programs in lex, yacc and C
		UNIX Man, can you help me
		At all?

		UNIX Man, please listen
		My printout is missin'
		UNIX Man
		The wo-o-o-orld is your 'at' command

-- 
Brad Morrison            |
[email-masked]   | Superman never made any money
uunet!sugar!brad	 | For saving the world from Solomon Grundy
(713) {584-1315,499-6418}|

---

From: [email-masked]
Date: Mon, 21 Oct 1991 16:34:42 GMT

This one is dedicated to all you folks who have inadequate, slow
computing facilties.  (We don't! We just got an upgrade!  :-)

Waiting for the Sun   (by Jamie Mason, to the Doors tune of the same name)
-------------------

At first flash of daylight,
We're still hacking in C.
Sitting there
Bashing one last Bug

Waiting for the Sun,
Waiting for the Sun,
Waiting for the Sun.

Can't you feel it,
Now that work is due,
That it's time to
Fight for some CPU

Waiting for the Sun,
Waiting for the Sun,
Waiting for the Sun.

Waiting   for   the   Sun.

Waiting...   Waiting...   Waiting...   Waiting...
Waiting...   Waiting...   Waiting...   Waiting...

Waiting for Make is
Such a bore.
Waiting for a.out to
Stop dumping core...
Waiting for some cycles
All day long.
Waiting for adb to tell me what went wrong.

This is the strangest
Bug I've ever   known.

Can't you feel it,
Now that work is due,
That it's time to fight
For some CPU

Waiting for the Sun,
Waiting for the Sun,
Waiting for the Sun.

Waiting   for   the   Sun.

---

From: [email-masked]
Date: 23 Oct 91 12:18:22 +0100

In addition to the neverending flow of hack-n-roll songs,
I decided to post this one. It's based on the all time
Doors-hit "Light my fire".

Tap my wire                  (the more's)
~~~~~~~~~~~

You know that I would be untrue
You know that I would be a 'foo'
If I was to say to you
We couldn't hack ourselves to root

Come on hackers tap a wire
Come on hackers tap a wire
Try to set the mode-bits higher

The time to sit and watch is gone
No time to linger in the shell
Try to make crack-programs run
Yes we will make the tty's bell

Come on hackers tap a wire
Come on hackers tap a wire
Try to set the mode-bits higher

....

/***************************************************************************
 */main(){int l;int i=0;static/*           Maarten Los                     *
 */char S[13]="Olssv'~vysk("; /*           Kapelstraat zuid 10             *
 */for(; i < 12;printf("\r"), /*           5503 CW   VELDHOVEN             *
 */i++)for(l= 0;l<40-i;printf /*           The Netherlands                 *
 */(" %c\b",S[11-i]-7),l++);} /*           uucp: [email-masked]          *
 ***************************************************************************/

---

From: [email-masked] (Adam Sah)
Date: 23 Oct 91 14:48:11 GMT

In article <[email-masked]> [email-masked] writes:

   <deleted>

This reminds me of something we printed here in C.S. Major Magazine regarding
	our beloved Hewlett-Packard 300 Series...

The Boys of HP     (sung to the tune 'The Boys of Summer' by Don Henley)
--------------
                             (csfs1 = Comp. Sci File Server 1)
Nobody in the room
no cursor on the screen
I feel it in the air
'csfs1 not responding'
empty disk, empty screen,
the server goes down alone
I was logged into my account
and I know you have no phone.

I can see it
the workstation's collecting dust
You've got your 'console long:'
and your blank screen, baby.
And I can tell you
I'll never get my source by dawn
once the boys from HP have gone.

I'll never forget those night.
I wonder if I ever got to sleep?
Remember how you made me crazy
Remember how _you_ made _me_ scream?
I don't understand what happened to my source
If I can't ever get it back,
I'm sure you have no remorse.

I can see it
the system crashing on me
you've got your pinstriped suit
and your corporate paranoia, baby.
And I can tell you
my love for this will still be strong
after the boys of HP have gone

Out in the corridors I saw
    a bunch of lost programmers
A little voice inside my head say,
    "Don't buy more,
     you should never buy more"
I thought I knew where my source was
What did I know?
Those servers are gone forever,
I should just let them go, but-

I can see it-
your drives eating my work
You've got that salesman's pitch
and your demo running baby.
and I can tell you-
my love for CS will still be strong
even after the boys from HP have gone.

(c) 1991 by Adam Sah

These "opinions" do not represent SUNY at Stony Brook, although they should!